Regarding the bug with the Mercedes 190E

Standard

SOARS team recently put out a video showing a peculiar bug with the Mercedes Benz 190E EVO II. It’s been known about for a while, but not many people have talked about it, so I thought I would do a quick post with relevant information to supplement their video.

Basically, it has to do with a clipping hitbox on the back quarter panels of the Mercedes 190E, causing the other vehicle to be instantly pushed back. If you want to test this yourself, it’s the easiest to reproduce in story mode with computer controlled cars.

In my testing, I found that rubbing while keeping the wheel straight is the easiest way to reproduce the bug. Here is a WEBM of my 190E performing the bug on a player vehicle.

Now while it doesn’t look like much, it definitely gives the 190E a very unfair priority in the battle neutral game, where the battle strength of each car can be a deciding factor to winning the neutral game.

The weird interactions with traffic and player cars can also cause the 190E to randomly teleport to the other side of the road. I unfortunately have no footage to prove it, since I’ve only seen it happen twice, but I have several eyewitnesses that will back up my claim. My best guess is that the glitching hitbox causes a desync in local battles in regards to true car position of player cars and ghosts.

The 190E is already a very strong battle car (review coming soon), but I think with MT5DX on the horizon for Japan, I’d imagine that the bug will get patched out very soon, since Japan will also be getting the 190E. While exploiting the glitch can be fun, I think its fair to patch it out to preserve the balance of the game.